Update: AT-ACT App Control Disabled?

We’ve received a report from Daniel B. in Australia stating that the latest update to the Hasbro’s Star Wars Studio FX app has disabled the wireless functionality of his AT-ACT. Click on through to read his account and if anyone else has this issue, let us know.

Update:  A new update was just issued today (March 16). Those with disabled app may want to give it a shot.

Hi guys

It appears the latest update on the 5th of March to the Star Wars Studio FX App has rendered the CONTROL! Function unusable i.e. you cannot control the AT-ACT remotely anymore. While the app still recognises the Walker, clicking on CONNECT results in a make sure your walker is nearby and turned on message every time, at least here in Australia. I have tried various devices, reinstalls etc. to overcome this with no success. My friend Leo F. has confirmed his AT-ACT has the exact same symptoms.

I have emailed Hasbro Australia to see what the deal is, was curious if this is also the case for you guys.

Regards

Daniel B.

  • Barney Dunn
  • The app was just updated today (March 16). Let us know if it fixed your downed AT-ACT.

    • Charles Belles

      Today’s update, which consisted of “Minor bug fixes and improvements”, did indeed get my AT-ACT working again!

  • Firestick User

    I’m trying to save $179.99 + tax to buy one before someone else snags the last two.

  • Rivesjunctionite

    This is why I never permit apps to auto update.

  • Brian Beck

    Well I’m not a smart phone/App guy, so I never tried that feature. I just got mine to be a center piece for a display. https://uploads.disquscdn.com/images/2e0a17b5a39ed592c1ffbb5f49ce7628acf632e81e0a7ca8bb6df8d49b01682e.jpg

  • General Hux

    AT-ACT-FAIL, bummer. 🙁

    • Rivesjunctionite

      I haven’t even got one yet, and it’s already broken.

  • 80sRobot

    BTW, the SW Movie FX app was updated today on my phone (Android). But now I can’t get it to launch. It crashes. I rebooted the phone, tried again, the app still crashes. Forced stopped it in Android OS settings, tried to launch it again, fail.

    It’s not an app I used much, just a trivial thing to tinker with. But I can’t imagine how I’d feel now if I had the AT-ACT.

    • 80sRobot

      Update:

      Cleared cache and downloaded files for the app. App still crashes when launched.

      Uninstalled app. Installed it again. Launch app. Still crashed. :

      Uninstalled, perhaps never to re-install. 😐

  • 80sRobot

    I wonder if a generic remote control could be programmed to operate this toy. Seems like a relatively trivial thing to do for the tech-hack community — I figure it’s pretty common in the RC community to program remote controls for a custom-built vehicles. I’m surprised I haven’t seen anything about this yet online.

    • Barney Dunn

      The Target exclusive Hasbro BB-8 came with a nice simple remote control. Sphero’s had an app but the Hasbro BB-8 is actually more fun and more a like a toy. No reason Hasbro has to try to pretend they are Sphero now. The app thing is a fad. A remote control AT-AT should be just that and they should have just included a low cost remote in the box. For those that want to play with buggy apps on their phones maybe have this option but they even say the app will be retired by 2018. Then what? Your toy is basically useless.

      • 80sRobot

        Yeah the whole toys-that-have-an-app-control thing is a total fad. I really do think a Bluetooth remote (probably something for less than $10) could be programmed to work the AT-ACT. It’s probably just some number codes you enter into such a remote, assigning them to each button press.

    • 80sRobot

      Another idea came to me: There are Bluetooth remote control apps that you can install on a phone that let you control your TV. I wonder if there’s such an app that lets you try to operate other devices (like the AT-ACT) that receive Bluetooth signals.

  • Super Amigo

    I don’t own the toy, but sometimes it happens that a buggy version of an app gets released in which some options or support for certain devices get broken.

    I want to think that Hasbro will very soon release a patched version that fixes all that.

    Unfortunately I was a fan of the REBELS game app for Android. As it happened, the last, current version of the game is broken: you get a white screen after startup, and that’s it. It only lets you play the first time you install it. They never fixed it, but I’m sure they’ll fix the AT-ACT app… no?

  • Dan-O Florez

    I noticed that it gives the toy a generic name, before it looked more like a serial number and less of a generic name like MWElephant. Hopefully it’s an easy fix. But this is annoying. Had I paid full price I’d be really mad right now! https://uploads.disquscdn.com/images/92a07fbc07a43a317e61541a40e954aa8af02846a60b0347977d3d7f915029c6.jpg https://uploads.disquscdn.com/images/8ee0928c9f148b2ece156ac4d27e9fbe326c43bcb58497e7fd3a250d8f6ddca2.png

    • 80sRobot

      I also wonder if a generic remote control device could be programmed to operate this toy. Seems like a relatively trivial thing to do for the tech-hack community — I figure it’s pretty common in the RC community to program remote controls for a custom-built vehicles.

      Cool paint mod, btw!

    • Brian Beck

      Yes, cool paint job.

  • Rykrof_Enloe

    Just another example of how terrible this whole concept was from day one. What were they thinking? This thing already tanked at retail, which the Star Wars team seems to not understand WHY… and now this… it’s almost comical… we can certainly add the AT-ACT(due the design team’s execution) to their portfolio of mistakes.

    I really hope the Star Wars team (or whoever is calling the shots) gets their act together soon, or gets replaced with people that have more common sense… their bad ideas just keep going, and going, and going… https://uploads.disquscdn.com/images/d9b629049ec18f0533b7e7aeb22bb5e4d2f6e440ad603ec4238d77851c7d72b3.jpg

  • Shabby Blue

    So basically it only worked for 3-4 months? What a worthless feature. It was this very feature that Hasbro used to justify the ridiculously high price for this product in the first place.

  • Feel free to state what type of device on which you are using the app.

    • CT-7567

      Do you think this toy would have been better off with a simple remote control?

  • Barney Dunn

    Just opened up mine and same issue. Only can control with the buttons on the toy. Called Hasbro they said they were aware of the problem.

  • Paulskywalker

    Hasbro are like ‘that’s it kids you’ve had tour fun, no more’. Great, make an RC vehicle that’ll only work while app is maintained.

  • Dave

    No way am I going to update then!